BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW X7 (G07) Forums General BMW X7 Forum iOS 13 Preview - New CarPlay Features

Post Reply
 
Thread Tools Search this Thread
      06-29-2019, 07:57 AM   #89
LittleJoe
Captain
LittleJoe's Avatar
United_States
286
Rep
632
Posts

Drives: 2019 BMW X7 xDrive 50i
Join Date: Mar 2019
Location: Reading, PA

iTrader: (0)

Quote:
Originally Posted by alistairg View Post
Quote:
Originally Posted by LittleJoe View Post
And just to update you on the number of successful reconnects, I'm still batting a 1000. I'm growing more optimistic iOS 13 has resolved the reconnect issue X7 owners have been experiencing with CarPlay.
Not to bring you down, but... I've had a couple of reconnect issues (but not a high percentage), as well as Apple Pay turning up a couple of times on the charging dock. I'm running iOS13b2 at the moment.
Do you own an X5 or an X7? And what version of iDrive are you at currently?
Appreciate 0
      06-29-2019, 01:34 PM   #90
LittleJoe
Captain
LittleJoe's Avatar
United_States
286
Rep
632
Posts

Drives: 2019 BMW X7 xDrive 50i
Join Date: Mar 2019
Location: Reading, PA

iTrader: (0)

Quote:
Originally Posted by alistairg View Post
Quote:
Originally Posted by LittleJoe View Post
And just to update you on the number of successful reconnects, I'm still batting a 1000. I'm growing more optimistic iOS 13 has resolved the reconnect issue X7 owners have been experiencing with CarPlay.
Not to bring you down, but... I've had a couple of reconnect issues (but not a high percentage), as well as Apple Pay turning up a couple of times on the charging dock. I'm running iOS13b2 at the moment.
I was in and out of our X7 12 times so far today and my iPhone reconnected every time.
Appreciate 0
      07-02-2019, 12:35 AM   #91
beanbaguk
Captain
beanbaguk's Avatar
Spain
281
Rep
895
Posts

Drives: BMW G30 520d M-Sport
Join Date: Feb 2015
Location: Costa del Sol

iTrader: (0)

Quote:
Originally Posted by MK2018 View Post
Quote:
Originally Posted by Nelson@BimmerTech View Post
Quote:
Originally Posted by jdarmstrong View Post
How did you get it to work? I have iDrive 6 and iOS 13 beta 2 but no widescreen CarPlay. I'm running NBTevo_L
You will first need to update your vehicle software from your local dealer to the latest available version. From there you can patch and enable full screen Carplay from a vendor.
Who is the best to get this patch done?
Drop me a PM. Happy to recommend a good coding service from experience.

Same for anyone else. It's not the cheapest, but it's quick, and offers support by WhatsApp answering all questions.

They also do other options and I'll get my speed limit FSC from them too.

Highly recommended.
__________________
Current car: 2017 BMW G30 520d M-Sport, BMW F46 218d Grand Tourer
Previous cars: 1989 BMW E30 316i, 1998 BMW E36 323i Coupe M Sport, 2009 BMW E87 116d, 2013 BMW F31 320d M-Sport
Appreciate 0
      07-03-2019, 05:42 AM   #92
LittleJoe
Captain
LittleJoe's Avatar
United_States
286
Rep
632
Posts

Drives: 2019 BMW X7 xDrive 50i
Join Date: Mar 2019
Location: Reading, PA

iTrader: (0)

My iPhone has successfully reconnected to iDrive 100% of the time since installing the iOS 13 public beta. IMO the connection issues related to iDrive 7 and the X7 will be resolved when iOS 13 is officially released in September.

I wonder if X5/iDrive 7 owners running the iOS 13 public beta are experiencing the same results.
Appreciate 0
      07-03-2019, 07:04 AM   #93
ppagiga
Captain
308
Rep
675
Posts

Drives: car
Join Date: Sep 2018
Location: MARS

iTrader: (0)

12.3.1, 11/2018.68 no issues
Appreciate 0
      07-03-2019, 07:45 AM   #94
jokinawa
First Lieutenant
228
Rep
338
Posts

Drives: 2019 X7 40i
Join Date: Apr 2016
Location: NY

iTrader: (0)

Just a heads up. I updated to IOS 13 Developer Beta 3 and I can connect to CarPlay but can't seem to get to the interface now.

Is anyone on IOS 13 DB3 and having the same issue?

2019/03.44
__________________
If my post was informative or helpful, please click the appreciate button. Thank you.
Appreciate 0
      07-03-2019, 12:15 PM   #95
OtisX7
First Lieutenant
OtisX7's Avatar
United_States
176
Rep
302
Posts

Drives: 2019 BMW X7 50i
Join Date: Mar 2019
Location: Long Island, NY

iTrader: (0)

Why does mine say 11/2018.55 and that my version is up to date, if there is a subsequent version?
Appreciate 0
      07-03-2019, 01:28 PM   #96
LittleJoe
Captain
LittleJoe's Avatar
United_States
286
Rep
632
Posts

Drives: 2019 BMW X7 xDrive 50i
Join Date: Mar 2019
Location: Reading, PA

iTrader: (0)

Quote:
Originally Posted by OtisX7 View Post
Why does mine say 11/2018.55 and that my version is up to date, if there is a subsequent version?
BMW isn't doing OTA updates but your dealer can install the latest version of iDrive. I had my X7 updated to March 2019.
Appreciate 0
      07-05-2019, 09:44 PM   #97
FreddyBMW
First Lieutenant
57
Rep
359
Posts

Drives: X7 40i
Join Date: Mar 2019
Location: USA

iTrader: (0)

Quote:
Originally Posted by LittleJoe View Post
BMW isn't doing OTA updates but your dealer can install the latest version of iDrive. I had my X7 updated to March 2019.
just a quick one...you said somewhere that Apple Maps shows directions on the dash...does it also show it on the HUD, if you had one? Thanks!
Appreciate 0
      07-05-2019, 10:34 PM   #98
alistairg
Lieutenant
88
Rep
459
Posts

Drives: 2019 X7 50i
Join Date: Jun 2009
Location: Seattle, WA, USA

iTrader: (0)

Garage List
2019 BMW X7 50i  [0.00]
Quote:
Originally Posted by FreddyBMW View Post
just a quick one...you said somewhere that Apple Maps shows directions on the dash...does it also show it on the HUD, if you had one? Thanks!
No.

Apple is talking about providing support for a second display, but it's not yet adopted by any manufacturer.
Appreciate 0
      07-06-2019, 05:37 PM   #99
jmciver
Major
jmciver's Avatar
United_States
581
Rep
1,246
Posts

Drives: 2017 M3, 2020 X7 40i
Join Date: Jul 2016
Location: DMV

iTrader: (0)

Garage List
2017 BMW M3  [0.00]
Quote:
Originally Posted by jokinawa View Post
Just a heads up. I updated to IOS 13 Developer Beta 3 and I can connect to CarPlay but can't seem to get to the interface now.

Is anyone on IOS 13 DB3 and having the same issue?

2019/03.44
Yup, same issue here - on my F80 anyway. The cost of "living on the edge" I guess ..... I would like to think there will be another beta release before iOS 13 goes final in Sep.
__________________
///M3COMPETITION 6MT - 2017 F80 Smoked Topaz Metallic
MP-HAS / GC Camber Plates / Carbonstructure Interior / Blackline Tail Lights

Appreciate 0
      07-08-2019, 09:10 PM   #100
LittleJoe
Captain
LittleJoe's Avatar
United_States
286
Rep
632
Posts

Drives: 2019 BMW X7 xDrive 50i
Join Date: Mar 2019
Location: Reading, PA

iTrader: (0)

iOS 13 Public Beta 1 has been working flawlessly for me, not a single CarPlay reconnect problem. I just downloaded iOS 13 Public Beta 2 and did a quick road test, still working but I'll post an update if I encounter any bugs while using CarPlay.
Appreciate 0
      07-08-2019, 09:23 PM   #101
jokinawa
First Lieutenant
228
Rep
338
Posts

Drives: 2019 X7 40i
Join Date: Apr 2016
Location: NY

iTrader: (0)

Quote:
Originally Posted by LittleJoe View Post
iOS 13 Public Beta 1 has been working flawlessly for me, not a single CarPlay reconnect problem. I just downloaded iOS 13 Public Beta 2 and did a quick road test, still working but I'll post an update if I encounter any bugs while using CarPlay.
Ugh. Both Developer beta 3 versions cause issues with CarPlay.
__________________
If my post was informative or helpful, please click the appreciate button. Thank you.
Appreciate 0
      07-09-2019, 03:40 AM   #102
beanbaguk
Captain
beanbaguk's Avatar
Spain
281
Rep
895
Posts

Drives: BMW G30 520d M-Sport
Join Date: Feb 2015
Location: Costa del Sol

iTrader: (0)

I should have added my comments here but I've been using public beta 2 and there are some huge improvements for CarPlay:

https://g30.bimmerpost.com/forums/sh...8#post25005668

Particularly UI updates and stability....
__________________
Current car: 2017 BMW G30 520d M-Sport, BMW F46 218d Grand Tourer
Previous cars: 1989 BMW E30 316i, 1998 BMW E36 323i Coupe M Sport, 2009 BMW E87 116d, 2013 BMW F31 320d M-Sport
Appreciate 0
      07-10-2019, 05:29 AM   #103
LittleJoe
Captain
LittleJoe's Avatar
United_States
286
Rep
632
Posts

Drives: 2019 BMW X7 xDrive 50i
Join Date: Mar 2019
Location: Reading, PA

iTrader: (0)

BMW had me bring the X7 into the shop for a software update. I'm now at 03/2019.60

They said this update addresses the connectivity issues for iPhones. As I've posted on this thread several times, since updating to iOS 13 I have not encountered any additional connection issues but if I notice any other changes or improvements I'll update this post.
Appreciate 0
      07-10-2019, 12:16 PM   #104
jmciver
Major
jmciver's Avatar
United_States
581
Rep
1,246
Posts

Drives: 2017 M3, 2020 X7 40i
Join Date: Jul 2016
Location: DMV

iTrader: (0)

Garage List
2017 BMW M3  [0.00]
Quote:
Originally Posted by LittleJoe View Post
BMW had me bring the X7 into the shop for a software update. I'm now at 03/2019.60

They said this update addresses the connectivity issues for iPhones. As I've posted on this thread several times, since updating to iOS 13 I have not encountered any additional connection issues but if I notice any other changes or improvements I'll update this post.
Just don't update to Beta 3 though. A very quick internet search reveals that iOS 13 Beta 3 has killed CarPlay across multiple car and car stereo manufacturers. Like you, iOS 13 Beta 2 worked flawless for me as well before I upgraded to Beta 3....
__________________
///M3COMPETITION 6MT - 2017 F80 Smoked Topaz Metallic
MP-HAS / GC Camber Plates / Carbonstructure Interior / Blackline Tail Lights

Appreciate 0
      07-10-2019, 01:41 PM   #105
Thrangster
Private First Class
35
Rep
120
Posts

Drives: Bmw x7
Join Date: May 2019
Location: New jersey

iTrader: (0)

Regardless of which 13 beta, there is a design flaw (I presume Apple's) with Wireless CarPlay - when connected this way, the phone largely believes it is connected to a wifi network (which it is) which it then presumes has internet connectivity (which it does not, as its only a closed network to the BMW system itself)

Thus, your iPhone is rendered useless for any internet access (it won't use cellular when connected to wifi (so Mail, web browsing, and third part apps say there is no internet connection.

Clearly, select Apple apps dont see this issue (Music, Mail, Siri searches etc.), so there must be some provision to know to use cellular when connected to a dead-end wifi network. But I cannot, for example, using the streaming Sirius XM app via CarPlay, or on the phone for that matter when connected to the car. I dont use Waze or Google Maps, but I wonder if they are impacted as well.

Has anyone noticed this, or know if there is a work-around?
Appreciate 0
      07-10-2019, 02:40 PM   #106
LittleJoe
Captain
LittleJoe's Avatar
United_States
286
Rep
632
Posts

Drives: 2019 BMW X7 xDrive 50i
Join Date: Mar 2019
Location: Reading, PA

iTrader: (0)

Quote:
Originally Posted by Thrangster View Post
Regardless of which 13 beta, there is a design flaw (I presume Apple's) with Wireless CarPlay - when connected this way, the phone largely believes it is connected to a wifi network (which it is) which it then presumes has internet connectivity (which it does not, as its only a closed network to the BMW system itself)

Thus, your iPhone is rendered useless for any internet access (it won't use cellular when connected to wifi (so Mail, web browsing, and third part apps say there is no internet connection.

Clearly, select Apple apps dont see this issue (Music, Mail, Siri searches etc.), so there must be some provision to know to use cellular when connected to a dead-end wifi network. But I cannot, for example, using the streaming Sirius XM app via CarPlay, or on the phone for that matter when connected to the car. I dont use Waze or Google Maps, but I wonder if they are impacted as well.
I use Apple Maps and Waze via CarPlay and they work great. What I don't know for sure if they are getting to the Internet via my iPhones cellular network or the BMW WiFi. I would guess cellular since I did not enable the built-in BMW WiFi for use with iPads and such.
Appreciate 0
      07-10-2019, 02:47 PM   #107
Thrangster
Private First Class
35
Rep
120
Posts

Drives: Bmw x7
Join Date: May 2019
Location: New jersey

iTrader: (0)

Quote:
Originally Posted by LittleJoe View Post
I use Apple Maps and Waze via CarPlay and they work great. What I don't know for sure if they are getting to the Internet via my iPhones cellular network or the BMW WiFi. I would guess cellular since I did not enable the built-in BMW WiFi for use with iPads and such.
But isn't your BMW wifi on for CarPlay connectivity - the process is that the connection starts with Bluetooth, and then it auto-negotiates a wifi connection with the car.

Yes, Maps works, as does Music streaming and Messages via CarPlay. But when the phone is connected this way, the phone itself is dead to the internet. See if your phone shows a DIRECTblah blah blah connection listed in Settings>Wifi when you are in the car and CarPlay is active. If so, try to browse with Safari or check mail.

Further, apps like SiriusXM are not working - no internet connection since the phone is connected to a dead-ended wifi point

If wifi is definitely not enabled in your car, then my connection process was very different. I had to turn wifi for in the car, and then follow the wireless carplay connect steps which silently and automatically connected to the BMW wifi access point as part fo the process (uses Bluetooth to commence the connection process and that connection negotiates the Wifi connection with no intervention on your part).
Appreciate 0
      07-10-2019, 03:33 PM   #108
JFU
Lieutenant
United_States
112
Rep
456
Posts

Drives: X7
Join Date: Apr 2009
Location: Boston, MA

iTrader: (3)

Quote:
Originally Posted by Thrangster View Post
But isn't your BMW wifi on for CarPlay connectivity - the process is that the connection starts with Bluetooth, and then it auto-negotiates a wifi connection with the car.

Yes, Maps works, as does Music streaming and Messages via CarPlay. But when the phone is connected this way, the phone itself is dead to the internet. See if your phone shows a DIRECTblah blah blah connection listed in Settings>Wifi when you are in the car and CarPlay is active. If so, try to browse with Safari or check mail.

Further, apps like SiriusXM are not working - no internet connection since the phone is connected to a dead-ended wifi point

If wifi is definitely not enabled in your car, then my connection process was very different. I had to turn wifi for in the car, and then follow the wireless carplay connect steps which silently and automatically connected to the BMW wifi access point as part fo the process (uses Bluetooth to commence the connection process and that connection negotiates the Wifi connection with no intervention on your part).
Wait, I'm confused. Can you not access any web content when connected to CarPlay? When I'm connected to CarPlay, my internet connectivity on my phone is fully active. I can stream videos, go to websites, check mail etc etc. I haven't activated the wifi hotspot either.
__________________
2014 A207 E550 Vert
2018 F60 Countryman S All4
2019 G07 X7 40i
Appreciate 0
      07-10-2019, 03:36 PM   #109
jokinawa
First Lieutenant
228
Rep
338
Posts

Drives: 2019 X7 40i
Join Date: Apr 2016
Location: NY

iTrader: (0)

Quote:
Originally Posted by JFU View Post
Quote:
Originally Posted by Thrangster View Post
But isn't your BMW wifi on for CarPlay connectivity - the process is that the connection starts with Bluetooth, and then it auto-negotiates a wifi connection with the car.

Yes, Maps works, as does Music streaming and Messages via CarPlay. But when the phone is connected this way, the phone itself is dead to the internet. See if your phone shows a DIRECTblah blah blah connection listed in Settings>Wifi when you are in the car and CarPlay is active. If so, try to browse with Safari or check mail.

Further, apps like SiriusXM are not working - no internet connection since the phone is connected to a dead-ended wifi point

If wifi is definitely not enabled in your car, then my connection process was very different. I had to turn wifi for in the car, and then follow the wireless carplay connect steps which silently and automatically connected to the BMW wifi access point as part fo the process (uses Bluetooth to commence the connection process and that connection negotiates the Wifi connection with no intervention on your part).
Wait, I'm confused. Can you not access any web content when connected to CarPlay? When I'm connected to CarPlay, my internet connectivity on my phone is fully active. I can stream videos, go to websites, check mail etc etc. I haven't activated the wifi hotspot either.
Most phones are smart enough to fallback to the LTE connection if the wireless network does not have internet.

My iPhone was able to do this while connected the BMW "WiFi Direct" network before activating the hotspot.

I have not experience the no internet issue unless I also had no LTE signal.
__________________
If my post was informative or helpful, please click the appreciate button. Thank you.
Appreciate 0
      07-10-2019, 03:41 PM   #110
JFU
Lieutenant
United_States
112
Rep
456
Posts

Drives: X7
Join Date: Apr 2009
Location: Boston, MA

iTrader: (3)

Quote:
Originally Posted by jokinawa View Post
Most phones are smart enough to fallback to the LTE connection if the wireless network does not have internet.

My iPhone was able to do this while connected the BMW "WiFi Direct" network before activating the hotspot.

I have not experience the no internet issue unless I also had no LTE signal.
That's what I thought too. I'm curious what's causing the inability to connect to the internet for Thrangster
__________________
2014 A207 E550 Vert
2018 F60 Countryman S All4
2019 G07 X7 40i
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:58 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST